@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > EIGRP(自動集約の問題)

 Amazon

@network Cisco・アライド実機で学ぶ
◆EIGRP(自動集約の問題)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク


◆EIGRP(自動集約の問題)

 EIGRPでは、クラスフル境界で自動的にルートの集約が行われます。複数のルートが要約されることによって、ルーティングテーブルのサイズが小さくなるので、ルータにとっては、ルーティングのオーバーヘッドが減ることになり望ましいことだと言えます。

それでは、下の図のネットワークをEIGRPで構築してみましょう!

ネットワークは、

(クラスB)-----(ルータA)-----(クラスC)-----(ルータB)-----(クラスB)

とネットワークは、Router_A、Router_Bのシリアルリンクででクラスフル境界になっています。


上の構成の場合、EIGRPでルーティングがちゃんと行えるのかどうかを検証してみます。


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 no ip address
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:02:49, Null0
C       172.16.1.0/24 is directly connected, Ethernet0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:03:35, Null0
C       172.16.3.0/24 is directly connected, Ethernet0


Router_Aには、「172.16.3.0/24」のルートがありません。

Router_Bには、「172.16.1.0/24」のルートがありません。


 Router_A、Router_BにおいてEIGRPで宛先ネットワークを正しく学習していません。当然ながら、Router_Aから「172.16.3.0/24」ネットワークへ対してのPingは失敗しますし、Router_Bから「172.16.1.0/24」ネットワークへ対してのPingも失敗します。


それは、

D 172.16.0.0/16 is a summary, 00:02:49, Null0

の出力から分かるとおり、「172.16.0.0/16」で自動的に要約しているからなのです。

 Ciscoルータ、IOSの組み合わせによっては、「show running-config」で確認すると、「auto-summary」が自動的に設定されていることを確認できます。ちなみに下の出力は、Cisco1721、IOS12.3の組み合わせの場合です。

router eigrp 1
network 172.16.0.0
network 192.168.1.0
auto-summary


 このように、EIGRPによる自動集約が望ましい結果にならない場合があります。このような場合、自動集約を無効にして手動で要約してあげる必要があります。


 続きは、「EIGRP(no suto-summary)」でルートを自動集約を無効にする方法と手動で要約する方法を紹介します。





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ
EIGRPの特徴
EIGRP(サクセサ・フィジブルサクセサ)
EIGRPの設定例1
EIGRP(検証コマンド)
EIGRP(debugコマンド)
EIGRP(ハロー間隔・ホールドタイム)
EIGRPとIGRPの混在時(自動再配布)
EIGRPの設定例2
EIGRP(show ip eigrp topology)
EIGRP(自動集約の問題)
EIGRP(no suto-summary)
EIGRP(MD5認証)その1
EIGRP(MD5認証)その2
EIGRP(手動経路集約)その1
EIGRP(手動経路集約)その2
EIGRP(手動経路集約)その3
EIGRP(手動経路集約)その4

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.