@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > 標準ACL

 Amazon

@network Cisco・アライド実機で学ぶ
◆標準ACL

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆標準ACL

ここでは、標準IPアクセスリストを作成して、インタフェースに適用して演習します。

まずは、下のネットワークをRIPで構成します。


次に標準IPアクセスリストを作成します。


◆標準IPアクセスリストの定義

標準IPアクセスリストの構文は以下のようになります。

Router(config)#access-list {番号} {permit | deny} {送信元IP} {ワイルドカードマスク}

種類 番号の範囲
標準IPアクセスリスト 1〜99    ※IOS12.0以降では、1,300〜1999も使用可能
拡張IPアクセスリスト 100〜199 ※IOS12.0以降では、2,000〜2699も使用可能

PCが所属する「192.168.1.0/24」から、Router_Bへのアクセスを禁止する標準IPアクセスリストを作成します。

access-list 1 deny 192.168.1.0 0.0.0.255
access-list 1 permit any

 「access-list 1 permit any」を定義するのを忘れては、いけません。このリストがないと暗黙の「deny any」があるために全ての通信が遮断されてしまいます。

ここで、PCからRouter_BへPingを行ってみます。

 


アクセスリストは、作成しただけで、まだインタフェースに適用していないのでPingが通ります。


◆アクセスリストの適用

Router(config-if)#ip access-group {番号} {in | out}

適用したいインタフェース設定モードで、「ip access-group」コマンドでアクセスリスト番号を指定します。

Router_B(config)#int s0
Router_B(config-if)#ip access-group 1 in

PCからRouter_BへPingを行ってみます。

 

アクセスリストで遮断されていることが確認できます。


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.2.1 255.255.255.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 ip access-group 1 in
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 192.168.2.0
!
ip classless
logging buffered
access-list 1 deny   192.168.1.0 0.0.0.255
access-list 1 permit any
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


次の「拡張ACL」では、拡張ACLの作成方法を紹介して演習を行います。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ACL(アクセスリスト)とは
ACL(ワイルドカードマスク)
ACL(host・anyキーワード・省略)
ACLの仕組・動作
標準ACL
拡張ACL
ACLの検証
拡張ACL
ACLの検証
名前付き標準IPアクセスリスト
名前付き拡張IPアクセスリスト
ACL アクセスクラス(access-class)
ACL(ICMP)
ACL(ルータの発行コマンド時の注意)
ACLの配置について
ACL(established)
ACL コンソールロギング(その1)
ACL コンソールロギング(その2)
ACL(VLAN間をフィルタリング)その1
ACL(VLAN間をフィルタリング)その2
ACLとNAT(その1)
ACLとNAT(その2)
ACLとSyslogサーバへの記録(その1)
ACLとSyslogサーバへの記録(その2)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.