@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > ACLとNAT(その1)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ACLとNAT(その1)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク


◆ACLとNAT(その1)

 Ciscoルータにおいて、NATやACL、ルーティングの設定などがある場合、アクセスリストはNAT変換後にチェックが行われるのか?NAT変換前にチェックが行われるのか?

疑問に思ったことがあると思います。

また、ルーティングはNAT変換後のIPアドレスを基に行われるのか?変換前のIPアドレスを基に行われるのか?

処理の順番について、疑問に思ったことがあると思います。

パケットがインターフェースに着信してから処理については、下表のように処理されます。参考(URL


Inside から Outside へ Outside から Inside へ
@IPSec の場合は入力アクセス リストをチェック

A復号化: CET または IPSec

B入力アクセス リストをチェック

C入力レート制限をチェック

D入力アカウンティング

EWeb キャッシュにリダイレクト

Fポリシー ルーティング

Gルーティング

HInside から Outside への NAT

Iクリプト(暗号化用のマップのチェックとマーク)

J出力アクセス リストをチェック

K検査(コンテキストベース アクセス制御(CBAC))

LTCP インターセプト

M暗号化

Nキューイング
@IPSec の場合は入力アクセス リストをチェック

A復号化: CET または IPSec

B入力アクセス リストをチェック

C入力レート制限をチェック

D入力アカウンティング

EWeb キャッシュにリダイレクト

FOutside から Inside への NAT

Gポリシー ルーティング

Hルーティング

Iクリプト(暗号化用のマップのチェックとマーク)

J出力アクセス リストをチェック

KCBAC 検査

LTCP インターセプト

M暗号化

Nキューイング

それでは、NAT使用時におけるACLの配置と処理の順番について説明してゆきます。

ネットワーク構成は、下図の通りです。


まずR_AとR_Bを上図のように設定します。

●R_Aの設定
!
hostname R_A
!
interface Ethernet0
 ip address 200.200.200.1 255.255.255.252
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
end

●R_Bの設定
!
hostname R_B
!
interface Ethernet0
 ip address 200.200.200.2 255.255.255.252
 half-duplex
!
end


◆R_Aにデフォルトルートを設定する

R_A(config)#ip classless
R_A(config)#ip route 0.0.0.0 0.0.0.0 200.200.200.2


◆R_AにPATを設定する

R_A(config)#access-list 1 permit 192.168.1.0 0.0.0.255
R_A(config)#ip nat inside source list 1 interface e0 overload
R_A(config)#int f0
R_A(config-if)#ip nat inside
R_A(config-if)#int e0
R_A(config-if)#ip nat outside

続きは、次の「ACLとNAT(その2)」で、ACLを配置してゆきます。





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ACL(アクセスリスト)とは
ACL(ワイルドカードマスク)
ACL(host・anyキーワード・省略)
ACLの仕組・動作
標準ACL
拡張ACL
ACLの検証
拡張ACL
ACLの検証
名前付き標準IPアクセスリスト
名前付き拡張IPアクセスリスト
ACL アクセスクラス(access-class)
ACL(ICMP)
ACL(ルータの発行コマンド時の注意)
ACLの配置について
ACL(established)
ACL コンソールロギング(その1)
ACL コンソールロギング(その2)
ACL(VLAN間をフィルタリング)その1
ACL(VLAN間をフィルタリング)その2
ACLとNAT(その1)
ACLとNAT(その2)
ACLとSyslogサーバへの記録(その1)
ACLとSyslogサーバへの記録(その2)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.