@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > ACL(established)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ACL(established)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ACL(established)

 フィルタの設定を行う際に、「内部からは許可したいが、外部からは、拒否したい」というケースがあります。この場合、「established」キーワードを使うことにより、簡単に実現することができます。

TCPのコネクションの確立の様子は、以下のようになります。これを3ウェイハンドシェイクと言います。


TCPにおける通信のやり取りでは、SYN、ACKを使ってコネクションを確立します。

ここで注目して欲しいのは、コネクション確立の最初のパケットには、ACKが付いていません。

2番目以降のパケットには、全てACKが付いています。

 つまり、外部から来るパケットでACKが付いていないもを拒否する設定ができれば、内部からの通信は、自由にし、、外部からの通信は、内部から通信の戻りパケットだけを通すことができそうです。

 それを可能にするオプションが、「established」です。「established」は、英語の意味で、「確立した」という意味があります。内部からコネクションが張られた通信だけ通すことができます。

 「established」オプションは、3ウェイハンドシェイクの仕組みを利用したフィルタリングなので、UDPでは使えないので注意して下さい。


それでは、実際に下のネットワークを構築して試してみます。



●HTTPサービスを有効にする

Router_Bでは、HTTPサービスを有効にして、Router_BをWebサーバとして代用します。

Router_BのHTTPサービスを有効にします。

Router_B(config)#ip http server


●Router_Aのアクセスリストの設定

Router_A(config)#access-list 100 permit tcp any any established
Router_A(config)#access-list 100 permit icmp any any echo-reply
Router_A(config)#access-list 100 permit icmp any any unreachable

Router_A(config)#int e0
Router_A(config-if)#ip access-group 100 out
※S0のINにアクセスリストを適用してもOKです。

PCから「192.168.2.2」にPingしてみます。



Pingは届きます。


PCから「192.168.2.2」にHTTP接続してみます。



HTTPサービスへ接続できることが確認できました。

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip access-group 100 out
!
interface Serial0
 ip address 192.168.2.1 255.255.255.0
 clockrate 64000
!
router rip
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
access-list 100 permit tcp any any established
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any unreachable
!
line vty 0 4
 password cisco
 login
!

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
!
router rip
 network 192.168.2.0
!
ip http server
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!

 このように、「established」キーワードは、「内部から発した通信は許可したいが、外部からの通信は、拒否したい」というケースに役に立つオプションです。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ACL(アクセスリスト)とは
ACL(ワイルドカードマスク)
ACL(host・anyキーワード・省略)
ACLの仕組・動作
標準ACL
拡張ACL
ACLの検証
拡張ACL
ACLの検証
名前付き標準IPアクセスリスト
名前付き拡張IPアクセスリスト
ACL アクセスクラス(access-class)
ACL(ICMP)
ACL(ルータの発行コマンド時の注意)
ACLの配置について
ACL(established)
ACL コンソールロギング(その1)
ACL コンソールロギング(その2)
ACL(VLAN間をフィルタリング)その1
ACL(VLAN間をフィルタリング)その2
ACLとNAT(その1)
ACLとNAT(その2)
ACLとSyslogサーバへの記録(その1)
ACLとSyslogサーバへの記録(その2)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.