@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > ACL アクセスクラス(access-class)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ACL アクセスクラス(access-class)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ACL アクセスクラス(access-class)

 Ciscoルータに適用できるアクセスリストは、物理インタフェースだけではありません。ここでは、ルータの仮想回線に適用するアクセスリストを紹介します。

 仮想回線に適用するアクセスリストのことをアクセスクラスと言います。アクセスクラスを使うことにより、ルータへのTelnetアクセスを制限できます。

下のネットワークを例にルータへのTelnetのアクセス制限について考えてみます。


Router_AへのTelnetアクセスを禁止したい場合について考えてみます。

 物理インタフェースにアクセスリストに適用させるとなると、Router_Aへの進入経路が、インタフェースの数だけあるわけですから、Telnetアクセスされる経路を考えて、アクセスリストを適用する物理インタフェースを決めなければなりませんし。

 複数の物理インタフェースから、Telnetアクセスされる可能性があるのであれば、Router_A上の全ての物理インタフェースにTelnetへのアクセスを禁止するアクセスリストを適用しなければならなくなってきます。

 そこで、便利なのがアクセスクラスです。全ての物理インタフェースにアクセスリストを設置しなくとも、ルータの仮想回線にアクセスリストを配置することで、ルータへのTelnetアクセスを制限することができます。


下のようにネットワークを構築し、アクセスクラスの設定を行ってみます。

PC1からのみRouter_AへのTelnetアクセスを禁止するように設定します。



◆アクセスクラスの設定

アクセスクラスの設定は、次の手順になります。

1.標準IPアクセスリストを作成する。

通常、Telnetへのアクセス制限は、送信元IPで制限する為、一般的に標準IPアクセスリストを使用します。

2.仮想回線(vty回線)にアクセスリストを適用する。

仮想回線(vty回線)にアクセスリストを適用するには、「access-class」コマンドを使用します。

Router(config)#line vty 0 4
Router(config-line)#access-class {アクセスリスト番号} {in | out}


●Router_Aのアクセスクラスの設定

Router_A(config)#access-list 1 deny host 192.168.1.10
Router_A(config)#access-list 1 permit any

Router_A(config)#line vty 0 4
Router_A(config-line)#access-class 1 in


●Router_Aの設定
!
version 11.2
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
 ip address 192.168.2.1 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
ip classless
access-list 1 deny   192.168.1.10
access-list 1 permit any
!
line con 0
line aux 0
line vty 0 4
 access-class 1 in
 password cisco
 login
!
end


PC1からRotuer_AにTelnetしてみます。




仮想回線ごとにアクセスリストを適用することもできますが、通常は、全てのVTY回線に対して同じ設定を行います。

次の「ACL(ICMP)」では、ICMPをフィルタリングするアクセスリストを紹介します。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ACL(アクセスリスト)とは
ACL(ワイルドカードマスク)
ACL(host・anyキーワード・省略)
ACLの仕組・動作
標準ACL
拡張ACL
ACLの検証
拡張ACL
ACLの検証
名前付き標準IPアクセスリスト
名前付き拡張IPアクセスリスト
ACL アクセスクラス(access-class)
ACL(ICMP)
ACL(ルータの発行コマンド時の注意)
ACLの配置について
ACL(established)
ACL コンソールロギング(その1)
ACL コンソールロギング(その2)
ACL(VLAN間をフィルタリング)その1
ACL(VLAN間をフィルタリング)その2
ACLとNAT(その1)
ACLとNAT(その2)
ACLとSyslogサーバへの記録(その1)
ACLとSyslogサーバへの記録(その2)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.