@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > スタティックルーティング(その1)

スポンサードリンク
@network Cisco・アライド実機で学ぶ
◆スタティックルーティング(その1)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆スタティックルーティング(その1)

 ルーティングテーブルの作成方法は、2つあります。

●スタティックルーティング(静的ルーティング)
●ダイナミックルーティング(動的ルーティング)

この2つのアプローチがあります。

 ここでは、スタティックルートの設定を行ってゆきます。

 スタティックルーティングとは、管理者がルータにネットワークのルート情報を手動で教えてあげる方法です。

 この方法は、宛先へのルートを固定する場合や、宛先へのルートが1つに限定される時に使います。

 スタティックルーティングとは、管理者がルータにネットワークのルート情報を手動で教えてあげる方法です。この方法は、宛先へのルートを固定する場合や、宛先へのルートが1つに限定される時に使います。

 スタティックルートの設定は、ルータにネットワーク上に存在する全ての宛先ネットワークの情報を教えてあげなくては、なりません。宛先ネットワーク情報が不足する場合、教えてあげていない、宛先へのルーティングが行えなくなります。

 ルータに教えてあげたルート情報は、ルーティングテーブルに追加されます。ルータは、パケットを受信すると、このルーティングテーブルを参照して、隣のルータ(送信インタフェース)にパケットを配送します。ルーティングテーブルに、宛先ネットワークへのエントリーが見つからない場合、配達不能になるので、パケットを破棄します。

 スタティックルーティングの欠点は、ネットワークの動的な変化に対応できないことです。ある経路に障害が発生した場合、迂回することができません。つまり、ネットワークの変更がある度に、管理者がルータを設定し直さなければなりません。

 長所は、ダイナミックルーティングのようにルーティング情報の交換が行われないので、帯域幅を圧迫しないので帯域幅の節約になります。また、ルート情報が、ルーティングアップデートとしてネットワーク上を流れることがないので、セキュリティ面において高い特徴があります。

それでは、下の図のように、シンプルなネットワークを構築してみましょう!


前の、「ルーティング(connected)」で紹介したように、ルータは、直接接続しているネットワークに関しては、特にルーティングに関する設定を行わなくても知っています。ただし、インタフェースには、IPアドレスを設定する必要があります。

スタティックルーティングの設定は、ルータが知らないネットワークを設定してゆきます。

それでは,Router_AとRouter_Bが知らないネットワークは、どのネットワークになるのでしょうか?

Router_Aは、直接接続していない、「192.168.3.0」ネットワーク
Router_Bは、直接接続していない、「192.168.1.0」ネットワーク

を知らないことになります。

ここで、気をつけて欲しいのは、通信は、行きと戻りがあるということです。

 例えば、PC_AからPC_Bに通信する場合、Router_Aだけが、「192.168.3.0」を含む全てのルートを持っていて、Router_Bが「192.168.1.0」のルートを知らなかったとします。

 宛先のPC_Bには、パケットが届けることができますが、戻りのパケットが、送信元であるPC_Aに届かないことになります。

 PC_AからPC_Bに送られるパケットの宛先ネットワークアドレスは、「192.168.3.0」になりますが、PC_Bに到着後の戻りのパケットの宛先ネットワークアドレスは、「192.168.1.0」になります。このネットワークのルートをRouter_Bが知らないと、戻りのパケットが破棄されてしまうのです。

つまり、

Router_Aには、「192.168.3.0」ネットワークへのルート
Router_Bには、「192.168.1.0」ネットワークへのルート

を教えてあげなければなりません。


◆スタティックルートの設定

スタティックルートの設定は、次のコマンドを使って設定します。

Router(config)#ip route <ネットワーク> <サブネットマスク> <ネクストホップ|インタフェース>

Router_Aに、「192.168.3.0」ネットワークへのルートを教えてあげるには、

Router(config)#ip route 192.168.3.1 255.255.255.0 192.168.2.1

 ネクストホップに、隣のルータのインタフェースのIPアドレスを指定します。隣のルータのIPアドレスと言っても、何でもいいわけではありません。Router_Aは、「192.168.3.0」ネットワークへパケットを送るために自分のS0インタフェースから送出するようになるので、その接続先であるRouter_BのS0インタフェースのIPアドレスを指定しなければなりません。

 ここでは、ネクストホップの指定の仕方として隣のルータのIPアドレスを指定しましたが、送信インタフェースを指定してもかまいません。

Router(config)#ip route 192.168.3.1 255.255.255.0 s0

と指定しても同様にルーティングできます。

ただし、インタフェースを指定できるのは、今回のように、ポイントツーポイント接続の場合のみです。

 Router_A、Router_Bの設定は、以下のようになります。出力結果は、機種、IOSのバージョンで若干異なる場合があります。

●Router_Aのコンフィグ
!
hostname Router_A
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.2.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
no ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2
!

●Router_Bのコンフィグ
!
hostname Router_B
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
!
no ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.1
!

設定が、完了したら、PC_AからPC_BへPingをしてみましょう!

Pingが成功するはずです。


◆ルーティングテーブルを確認する

それぞれのルータでルーティングテーブルを確認してみましょう!

Router#show ip route

●Router_Aの「show ip route」の出力
Router_A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0
C    192.168.2.0/24 is directly connected, Serial0
S    192.168.3.0/24 [1/0] via 192.168.2.2

●Router_Bの「show ip route」の出力
Router_B#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route

Gateway of last resort is not set

S    192.168.1.0/24 [1/0] via 192.168.2.1
C    192.168.2.0/24 is directly connected, Serial0
C    192.168.3.0/24 is directly connected, Ethernet0

上の出力で、黄色く網掛けしている部分に注目して下さい。

Router_Aでは、

S 192.168.3.0/24 [1/0] via 192.168.2.2

Router_Bでは、

S 192.168.1.0/24 [1/0] via 192.168.2.1

 「S」というマークが付いています。これは、「static」と言う意味です。その経路がスタティックルートであることを示しています。これらのルートは、インタフェースがダウンすると消えてなくなってしまいます。インタフェースがダウンした場合、ルートが消えないようにするには、「parmanent」オプションを指定すると、消えなくなりますが、ここでは、割愛します。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルーティング(connected)
スタティックルーティング(その1)
スタティックルーティング(その2)
デフォルトルートとip classless

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.