@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > SSHで接続する(その1)

スポンサードリンク
@network Cisco・アライド実機で学ぶ
◆SSHで接続する(その1)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆SSHで接続する(その1)

 SSH(セキュアシェル)は、ネットワークデバイスへセキュアなターミナルエミュレーション接続を確立するために使用されるプロトコルです。SSHを使用してルータを管理することができます。

 Telnetでは、クライアントとサーバ間の認証や暗号化を行うことができません。つまり、ネットワーク上に流れるトラフィックをスニファを使用することで傍受されてしまう恐れがあります。SSHは、Telnetと同様にTCP/IPベースのプロトコルで、セキュアな接続ができることから、Telnetに取って代りつつあります。

 ここでは、ルータにSSH接続を行う方法を紹介してゆきます。

PCとルータとの接続は、下の図のようにします。


●IPアドレスを割り当てる

PCとルータが通信できるようにルータのF0インタフェースにIPアドレスを割り当てる必要があります。

ここでは、ドメイン名は、適当に「ccna.com」にしています。

Router(config)#hostname Router_A
Router_A(config)#ip domain-name ccna.com
Router_A(config)#interface f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit

●特権レベル15で定義されたユーザアカウントを作成する

 adminユーザの特権レベルは、15(最高)であり、特権レベル15がvty回線に設定されているため、TelnetもしくはSSHで接続では、特権レベル15で定義されたユーザアカウントが要求されます。

ここでは、ユーザ名「ccnaccnp」、パスワード「ccnaccnp」でユーザアカウントを作成しておきます。

Router_A(config)#username ccnaccnp privilege 15 password 0 ccnaccnp

 次のように、Telnet(0〜4)回線に対して、特権レベル15を割り当て、ローカルログイン、SSH/Telnetを設定します。

Router_A(config)#line vty 0 4
Router_A(config-line)#privilege level 15
Router_A(config-line)#login local
Router_A(config-line)#transport input telnet ssh
Router_A(config-line)#exit

●ルータのRSA暗号キーペアを生成する

Router_A(config)#crypto key generate rsa

デフォルトのモジュラスビットの数値は、512です。ここでは、デフォル値で生成します。

Router_A(config)#crypto key generate rsa
The name for the keys will be: Router_A.ccna.com
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]:
% Generating 512 bit RSA keys, keys will be non-exportable...[OK]

Router_A(config)#

上で紹介した設定は、グローバル設定モードで以下のコンフィグを流し込むことでも設定できます。

hostname Router_A
ip domain-name ccna.com
interface f0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username ccnaccnp privilege 15 password 0 ccnaccnp
line vty 0 4
privilege level 15
login local
transport input telnet ssh
exit

●show ip ssh

SSHが有効で、どのバージョンが使用されているかを確認するには、「show ip ssh」コマンドを使用します。

Router_A#show ip ssh

●「show ip ssh」の出力
Router_A#show ip ssh
SSH Enabled - version 1.99
Authentication timeout: 120 secs; Authentication retries: 3

続きは、次の「SSHで接続する(その2)」で、ターミナルソフトからSSHを使用して、ルータに接続してみます。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.