@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > インタフェースの設定

スポンサードリンク
@network Cisco・アライド実機で学ぶ
◆インタフェースの設定

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆インタフェースの設定

 インタフェースの設定を行うには、インタフェースコンフィグレーションモードに切り替えます。

 設定できるインタフェースは、ルータによって、また、差し込んでいるモジュールによって変わってきますが、主にSerial、Ethernet、FastEthernetなどを設定します。

 インタフェースコンフィグレーションモードに切り替えるには、次のコマンドを入力します。

Router(config)#interface {タイプ}{ポート番号}

 インタフェースのタイプを指定するので、インタフェースの名称を覚える必要があります。

モジュール差込口

●インタフェースのタイプ
コマンド タイプ コマンド タイプ
Serial シリアル bri ISDN BRI
Ethernet イーサネット dialer ダイヤラー
FastEthernet ファストイーサネット loopback ループバック
token ring トークンリング null ヌル
fddi FDDI async 非同期シリアル
hssi HSSI tunnel トンネル


◆インタフェースコンフィグレーションモードへの切り替え

インタフェースコンフィグレーションモードに切り替えるには、以下のコマンドを使用します。

Router(config)#interface <タイプ><ポート番号>

または、

Router(config)#interface <タイプ><スロット番号>/<ポート番号>

と指定します。

 モジュールで追加したインターフェースだけが、<タイプ><スロット番号>/<ポート番号>のような指定をするとは限りません。標準で搭載されているインタフェースでも<タイプ><スロット番号>/<ポート番号>で指定する場合があります。

 どちらで、インタフェースコンフィグレーションモードに入ったらよいのかは、「show running-config」すれば、分かるようになっています。<タイプ><スロット番号>/<ポート番号>で指定すればいいことが分かります。

interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!

上の場合だと、下のように入力すれば、インタフェースコンフィグレーションに切り替えられます。

Router(config)#interface ethernet 0/0

 続けて、他のインタフェースを設定したいのであれば、下のように、いったんグローバルコンフィグレーションモードに戻ってから、再度、インターフェースを指定してもよいし

Router(config)#interface ethernet 0/0
Router(config-if)#exit
Router(config)#interface ethernet 0/1
Router(config-if)#

グローバルコンフィグレーションモード戻らないで、他のインタフェースに切り替えてもよいです。

ただ、その際は、「TAB」でコマンドを補完できないので注意して下さい。

Router(config)#interface ethernet 0/0
Router(config-if)#interface ethernet 0/1


◆IPアドレスの設定

 インタフェースにIPアドレスを振るには、「ip address」コマンドを使います。同じIPアドレスや、ネットワーク範囲が重複してしますIPアドレスは、設定できないので、注意して下さい。

Router(config-if)#ip address <IPアドレス> <サブネットマスク>

インタフェースは、デフォルトでdownしています。つまり、「shutdown」されているので、「up」するのを忘れないようにしましょう!

Router(config-if)#no shutdown

例えば、こんな感じで設定します。

Router(config)#interface e0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#


◆インタフェースの無効化・有効化

 ルータの初期状態は、全てのインタフェースが管理目的で、無効になっています。つまり「down」状態になっています。インタフェースを使用するには、有効にする必要があります。

●インタフェースの有効化

Router(config-if)#no shutdown

●インタフェースの無効化

Router(config-if)#shutdown

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.