@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > スティッキ ポートセキュリティ(その2)

 Amazon
@network Cisco・アライド実機で学ぶ
◆スティッキ ポートセキュリティ(その2)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



◆スティッキ ポートセキュリティ(その2)

スティッキ ポートセキュリティ(その1)」の続きです。

S_Aのf0/5は、PC1のMACアドレスで関連付けられています。


PC1とS_Aとの接続を切り離し、PC2をS_Aのf0/5に接続します。


PC2から、S_AにPingを行います。

C:¥>ping 192.168.1.1

pingは失敗します。
※f0/5がシャットダウンされるまでには、タイムラグがありますので、しばらくは、Pingは成功します。

●show port-security interface 0/[番号]

次のコマンドを入力します。

S_A#show port-security interface fastEthernet 0/5

●S_Aの「show port-security interface fastEthernet 0/5」の出力
S_A#show port-security interface fastEthernet 0/5
Port Security              : Enabled
Port Status                : Secure-shutdown
Violation Mode             : Shutdown
Aging Time                 : 0 mins
Aging Type                 : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses      : 1
Total MAC Addresses        : 1
Configured MAC Addresses   : 0
Sticky MAC Addresses       : 1
Last Source Address        : 0018.f323.20b5
Security Violation Count   : 1

黄色の網掛けを見て下さい。S_Aのf0/5がシャットダウンになっています。

●show port-security

「show port-security」コマンドは、ポートセキュリティの設定を確認することができます。

次のコマンドを実行します。

S_A#show port-security

●S_Aの「show port-security」の出力
S_A#show port-security
Secure Port  MaxSecureAddr  CurrentAddr  SecurityViolation  Security Action
                (Count)       (Count)          (Count)
---------------------------------------------------------------------------
      Fa0/5              1            1                  1         Shutdown
---------------------------------------------------------------------------
Total Addresses in System (excluding one mac per port)     : 0
Max Addresses limit in System (excluding one mac per port) : 1024

「f0/5」にポートセキュリティの設定が行われており、違反カウントが増加していることが確認できます。

インタフェースの状態を確認します。

S_A#show int f0/5

●S_Aの「show int f0/5」の出力
S_A#sh int f0/5
FastEthernet0/5 is down, line protocol is down (err-disabled)
  Hardware is Fast Ethernet, address is 0006.2afb.9f85 (bia 0006.2afb.9f85)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:02:11, output 00:02:11, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     119 packets input, 21450 bytes, 1 no buffer
     Received 110 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 1 ignored
     0 watchdog, 31 multicast, 0 pause input
     0 input packets with dribble condition detected
     2742 packets output, 202786 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

セキュリティ違反となり、ポートが「err-disabled」となり、ダウンしていることが分かります。


◆S_Aスイッチの再起動を行う

「reload」コマンドでの再起動もしくは、電源を切ってから、S_Aスイッチを再起動させます。

PC1のMACアドレスを学習する前に、保存している必要があります。

実行コンフィグを確認します。

S_A#show run

●S_Aの「show run」の出力
(略)
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport mode access
 switchport port-security
 switchport port-security mac-address sticky
!
interface FastEthernet0/6
!
(略)

 学習され、実行コンフィグ(running-config)に追加されていたPC1のMACアドレスが消えています。理由は、再起動したことで、PC1のMACアドレスが学習される前に保存したstartup-configの設定に戻ったからです。

 スティッキポートセキュリティでは、学習した内容は、running-configに保存されるため、再起動後も学習した内容をそのまま利用したい場合は、「copy run start」しておく必要があります。

PC2から、S_AにPingを行います。

C:¥>ping 192.168.1.1

pingは成功します。

再度、実行コンフィグを確認します。

S_A#show run

●S_Aの「show run」の出力
(略)
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport mode access
 switchport port-security
 switchport port-security mac-address sticky
 switchport port-security mac-address sticky 0018.f323.20b5
!
interface FastEthernet0/6
!
(略)

PC2のMACアドレスが学習され、実行コンフィグ(running-config)に追加されていることが確認できます。


◆MACアドレスの関連付けをクリアする

学習した関連付けをクリアするには、以下のコマンドを実行します。

スティッキポートセキュリティーの設定を無効にします。

S_A(config)#int f0/5
S_A(config-if)#no switchport port-security mac-address sticky

インタフェースを再起動させます。

S_A(config-if)#shutdown
S_A(config-if)#no shutdown

再度、スティッキポートセキュリティーの設定を有効にします。

S_A(config)#int f0/5
S_A(config-if)#switchport port-security mac-address sticky

これで、スイッチS_Aは、ポートとMACアドレスの関連付けの学習が、再び行えるようになります。

スティッキ ポートセキュリティ(その1)」 ← 前項





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.