@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > SSHで接続する(その1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆SSHで接続する(その1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆SSHで接続する(その1)

 SSH(セキュアシェル)は、ネットワークデバイスへセキュアなターミナルエミュレーション接続を確立するために使用されるプロトコルです。SSHを使用してルータを管理することができます。

 Telnetでは、クライアントとサーバ間の認証や暗号化を行うことができません。つまり、ネットワーク上に流れるトラフィックをスニファを使用することで傍受されてしまう恐れがあります。SSHは、Telnetと同様にTCP/IPベースのプロトコルで、セキュアな接続ができることから、Telnetに取って代りつつあります。

ここでは、ルータにSSH接続を行う方法を紹介してゆきます。


◆ルータの初期設定

WebブラウザからのGUI操作を可能にするには、ルータの初期設定が必要です。

PCとルータとの接続は、下の図のようにします。


●IPアドレスを割り当てる

PCとルータが通信できるようにルータのF0インタフェースにIPアドレスを割り当てる必要があります。

Router(config)#interface f0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

●HTTP/HTTPSサーバを有効にする

ルータのHTTP/HTTPSサーバ機能を有効にします。

Router(config)#ip http server
Router(config)#ip http secure-server
Router(config)#ip http authentication local

●特権レベル15で定義されたユーザアカウントを作成する

SDMでは、特権レベル15で定義されたユーザアカウントが要求されます。

 初回のSDMへの接続時に変更するように要求されますが、ここでは、ユーザ名「ccnaccnp」、パスワード「ccnaccnp」でユーザアカウントを作成しておきます。

Router(config)#username ccnaccnp privilege 15 password 0 ccnaccnp

 SDMでは、特権レベル15では、次のように、Telnet(0〜4)回線に対して、特権レベル15を割り当て、ローカルログイン、SSH/Telnetを設定する必要があります。

Router(config)#line vty 0 4
Router(config-line)#privilege level 15
Router(config-line)#login local
Router(config-line)#transport input telnet
Router(config-line)#exit

※SSHも設定する場合は、「transport input telnet」ではなく、「transport input telnet ssh」と指定しますが、ここでは、Telnetだけを指定しておきます。

※CLIで、「transport input telnet ssh」と指定すれば、この後の設定は必要ありません。

上で紹介した設定は、グローバル設定モードで以下のコンフィグを流し込むことでも設定できます。

interface f0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username ccnaccnp privilege 15 password 0 ccnaccnp
line vty 0 4
privilege level 15
login local
transport input telnet
exit

DNSサーバの指定(その2)」 ← 前項 | 次項 → 「SSHで接続する(その2)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.