@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > DHCPの設定

 Amazon
@network Cisco・アライド実機で学ぶ
◆DHCPの設定

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆DHCPの設定

 DHCP(Dynamic Host Configuration Protocol)は、IPアドレスなど必要な情報を自動的に割り当てる機能です。DHCPサーバは、クライアントの要求に対して、あらかじめプールされたIPアドレスの中から、使用されていないアドレスを選び、一定の期間、クライアントに割り当てます。

 IPアドレスだけでなく、デフォルトゲートウェイやDNSサーバのIPアドレス、サブネットマスクなど、同一サブネット内で共通して使われるパラメータも配布することができます。また、クライアントが通信を終えると自動的にアドレスを回収し、他のコンピュータにそのアドレスを割り当てることで、効率の良いIPアドレスの払い出しを実現しています。

 ネットワーク管理者は、DHCPを使うことで、繁雑になりがちな、クライアントに割り当てるIPアドレスをはじめとする各種パラメータの管理を容易に一元的管理することができます。クライアントの数が多ければ多いほど、DHCP機能の恩恵は大きなものとなります。

 前置きは、これぐらいにしておいて、ここでは、CiscoルータにDHCP機能を設定してゆきます。管理人の知る限り、ほとんどのCiscoルータでDHCPをサポートしています。

ネットワーク構成は、下図のようになります。


●プールの作成

 DHCPのプールを作成するには、まず、「ip dhcp pool」コマンドを入力します。するとプロンプトが、「dhcp-config」に変わります。

 そこで、プールのアドレスの範囲を指定したり、デフォルトゲートウェイ、DNSサーバ、WINSサーバなどを指定します。

Router(config)#ip dhcp pool {プール名}
Router(dhcp-config)#network {ネットワークアドレス} {サブネットマスク}
Router(dhcp-config)#default-router {デフォルトゲートウェイのIPアドレス}
Router(dhcp-config)#dns-server {DNSサーバのIPアドレス}

他にも

Router_A(dhcp-config)#?

で確認すると以下のオプションも用意されています。

Router_A(dhcp-config)#?
DHCP pool configuration commands:
  bootfile             Boot file name
  client-identifier    Client identifier
  client-name          Client name
  default-router       Default routers
  dns-server           DNS servers
  domain-name          Domain name
  exit                 Exit from DHCP pool configuration mode
  hardware-address     Client hardware address
  host                 Client IP address and mask
  import               Programatically importing DHCP option parameters
  lease                Address lease time
  netbios-name-server  NetBIOS (WINS) name servers
  netbios-node-type    NetBIOS node type
  network              Network number and mask
  next-server          Next server in boot process
  no                   Negate a command or set its defaults
  option               Raw DHCP options

●IPアドレスの除外

 ネットワーク内には、ルータや各種サーバが存在します。それらのIPアドレスとDHCPで払い出すIPアドレスが重複するとネットワークが機能しなくなってしまいます。

 「ip dhcp excluded-address」コマンドを使用するとプールの中から除外するIPアドレスを設定することができます。

・範囲を指定して除外する場合

Router(config)#ip dhcp excluded-address {除外する開始IPアドレス} {除外する終了IPアドレス}

・単独指定で除外する場合

Router(config)#ip dhcp excluded-address {除外するIPアドレス}

◆PC1の設定

PC1のIPアドレスは、自動取得にしておきます。



◆ルータの設定

Router_Aで次の設定を行います。

●Router_A

Router_A(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.10
Router_A(config)#ip dhcp pool sales
Router_A(dhcp-config)#network 172.16.1.0 255.255.255.0
Router_A(dhcp-config)#default-router 172.16.1.1
Router_A(dhcp-config)#dns-server 172.16.1.2

●Router_Aの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
ip dhcp excluded-address 172.16.1.1 172.16.1.10
!
ip dhcp pool sales
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1
   dns-server 172.16.1.2
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface FastEthernet0
 ip address 172.16.1.1 255.255.0.0
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

同一セグメントに複数のDHCPサーバがある場合」 ← 前項 | 次項 → 「DHCPサーバの配置について





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.