@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > BGPの基本設定(その1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆BGPの基本設定(その1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆BGPの基本設定(その1)

ここでは、BGPを使って下図のネットワークを構築します。

 BGPの設定は、様々な属性を与えて経路選択を操作することができるため、少々設定が複雑ですが、CCENT、CCNAでは、詳しい内容は試験範囲外となります。。

ここでは、BGPの基本的な設定を紹介します。

 今回、検証に使用したのは、Cisco2500シリーズのルータです。Cisco2500ルータは、中古で安く入手できるコストパフォーマンスに優れたルータです。

もちろん、BGPの動作確認も行えます。

使用するネットワークは、下図になります。


今回のBGPの基本設定では、以下のことを行います。

・AS100内の「10.10.10.0/24」のルートをAS200に通知する。
・AS200内の「20.20.20.0/24」のルートをAS100に通知する。


BGPの設定の流れ

1.BGPプロセスを有効にする。

Router(config)#rotuer bgp [AS番号]

2.ピアを確立する近接ルータを指定する。

IGPのように自動でネイバーの登録は、行われません。管理者がネイバーの登録を行います。

Router(config-router)#neighbor [ピアを張るルータのIP] remote-as [AS番号]

3.通知する経路を指定する。

Router(config-router)#network [ネットワークIP] mask [サブネットマスク]


BGP同期の設定

 BGPでは、『たとえBGPで経路情報を学習してもIGPで学習するまでは、その経路情報を有効にしない。』というBGP同期という機能があります。

 このBGP同期の機能は、IOS12.2(8)以前のバージョンでは、デフォルトで有効になっています。ここでは、この機能を無効にしておきます。

Router(config-router)#no synchronization


●Router_Aの設定

Router_AのBGPルーティングの設定は、以下のようになります。

Router_Aが所属するASは、100です。BGPのプロセスを100で指定します。

Router_A(config)#router bgp 100

次に、ピアを張るBGPスピーカーのIPアドレスを指定し、そのBGPスピーカーが所属するAS番号を指定します。

Router_A(config-router)#neighbor 172.16.0.2 remote-as 200

最後に、BGPで通知する経路情報を指定します。

Router_A(config-router)#network 10.10.10.0 mask 255.255.255.0
Router_A(config-router)#no auto-summary

●Router_Bの設定

Router_B(config)#router bgp 200
Router_B(config-router)#neighbor 172.16.0.1 remote-as 100
Router_B(config-router)#network 20.20.20.0 mask 255.255.255.0
Router_B(config-router)#no auto-summary

●各ルータの設定

それでは、ルータを設定してゆきます。各ルータの設定は、下のようになります。

 強制的にインタフェースをUPさせるために、Router_AのE0インタフェースで「no keepalive」コマンドを設定しておきます。

●Router_Aの設定
!
version 11.2
!
hostname Router_A
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
router bgp 100
 network 10.10.10.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 200
 no auto-summary
!
ip classless
!
end

●Router_Bの設定
!
version 11.2
!
hostname Router_B
!
interface Ethernet0
 ip address 20.20.20.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
router bgp 200
 network 20.20.20.0 mask 255.255.255.0
 neighbor 172.16.0.1 remote-as 100
 no auto-summary
!
ip classless
!
end

各ルータのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [20/0] via 172.16.0.2, 00:05:04
C    172.16.0.0/16 is directly connected, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [20/0] via 172.16.0.1, 00:03:38
     20.0.0.0/24 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, Ethernet0
C    172.16.0.0/16 is directly connected, Serial0

ここで、もう一度、設定したことを確認してみます。

Router_Aには、BGPのルート「20.20.20.0」のルートがあります。

Router_Bには、BGPのルート「10.10.10.0」のルートがあります。

 設定は、簡単だったと思います。RIP、IGRP、EIGRPなどのルーティングプロトコルと大して変わらないと思ったかもしれません。これぐらいの内容が、CCENT、CCENTの試験範囲です。しかし、BGPの設定は、奥が深く、これから先の内容は、ちょっと勝手が違ってきます。どう違うのかは、この後のコンテンツで紹介してゆきます。

この続きは、「BGPの基本設定(ベストパスの確認 その2)」で、設定した内容を検証してゆきます。

BGP(近隣関係の形成)」 ← 前項 | 次項 → 「BGPの基本設定(ベストパスの確認 その2)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.