@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > IGRPとRIPの混在時

 Amazon
@network Cisco・アライド実機で学ぶ
◆IGRPとRIPの混在時

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆IGRPとRIPの混在時

 IGRPとRIPの設定の両方を行った場合、IGRPで選出されたルート、RIPで選出されたルートのどちらが優先されるかを検証してみます。


まずは、RIPで構成します。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

RIPでネットワークを構築したのでもちろん、それぞれのルータでRIPのルートが登録されています。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:02, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:24, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

このRIPの設定に、IGRPの設定を加えます。

Router_Aで、IGRPの設定を追加します。

Router(config)#router igrp 1
Router(config-router)#network 172.16.0.0
Router(config-router)#network 172.17.0.0

Router_Bでは、IGRPの設定を追加します。

Router(config)#router igrp 1
Router(config-router)#network 172.17.0.0
Router(config-router)#network 172.18.0.0

と設定します。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
router igrp 1
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
router igrp 1
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

設定が完了したら、「show ip route」コマンドで、ルーティングテーブルを確認してみましょう!

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
I    172.18.0.0/16 [100/8576] via 172.17.0.2, 00:00:11, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

I    172.16.0.0/16 [100/8576] via 172.17.0.1, 00:00:17, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

先ほどのRIPのルートが消え、IGRPのルートに上書きされていることが分かります。

それでは、Ciscoルータは、何を基準にしてルーティングテーブルに登録する経路を決めているのでしょうか?

 それは、アドミニストレーティブディスタンス(Administrative Distance)という値が関係してきます。アドミニストレーティブディスタンス値は、下の表のように定義されています。

経路情報 アドミニストレーティブディスタンス値
直接接続の経路 0
スタティックルート 1
EIGRPサマリ 5
外部BGP 20
EIGRP内部ルート 90
IGRP 100
OSPF 110
IS-IS 115
RIP 120
EGP 140
EIGRP外部ルート 170
内部BGP 200
不明(Unkown) 255

 ルーティングプロトコルで学習した経路は、アドミニストレーティブディスタンス値の小さい方を信頼性が高いと判断して、ルーティングテーブルに登録します。

ルータにRIP、IGRPの両方の設定を行った場合だと

RIP ・・・ 120
IGRP ・・・ 100

になります。

従って

 アドミニストレーティブディスタンスの値が小さいIGRPによって学習された経路がルーティングテーブルに登録されるようになるのです。

次の「IGRP(不等コストロードバランシング)」では、IGRPの不等ロードバランシングについて紹介します。

IGRPの設定例2」 ← 前項 | 次項 → 「IGRP(不等コストロードバランシング)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.