@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > IGRPの設定例2

 Amazon
@network Cisco・アライド実機で学ぶ
◆IGRPの設定例2

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆IGRPの設定例2

 「IGRPの設定例1」では、クラスフルでIGRPネットワークを構成しました。今度は、連続サブネット間でルーティングしてみます。IGRPでは、不連続サブネットでルーティングはできません。


今度は、連続サブネットでネットワークが構築されています。

 (172.16.1.0/24)-----(ルータ)-----(172.16.2.0/24)-----(ルータ)-----(172.16.3.0/24)

になります。

Router_Aでは、IGRPの設定を

Router(config)#router igrp <AS番号>
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0

Router_Bでは、IGRPの設定を

Router(config)#router igrp <AS番号>
Router(config-router)#network 172.16.2.0
Router(config-router)#network 172.16.3.0

と設定したいところですが、

Router_Aでは、IGRPの設定を

Router(config)#router igrp <AS番号>
Router(config-router)#network 172.16.0.0

Router_Bでも同様に、IGRPの設定を

Router(config)#router igrp <AS番号>
Router(config-router)#network 172.16.0.0

に設定します。

 IGRPの「network」コマンドの設定は、直接接続しているネットワークをクラスフルで指定するとこを忘れては、いないでしょうか?

 「network」コマンドは、指定されたネットワークアドレスに含まれるIPアドレスを持つインタフェースをIGRPに関連付けます。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
router igrp 1
 network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 bandwidth 64
 no fair-queue
!
router igrp 1
 network 172.16.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

設定が完了したら、「show ip route」コマンドで、ルーティングテーブルを確認してみましょう!

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, Ethernet0
C       172.16.2.0 is directly connected, Serial0
I       172.16.3.0 [100/8576] via 172.16.2.2, 00:00:56, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
I       172.16.1.0 [100/8576] via 172.16.2.1, 00:00:03, Serial0
C       172.16.2.0 is directly connected, Serial0
C       172.16.3.0 is directly connected, Ethernet0

ところで、

Router_Aで、IGRPの設定を

Router(config)#router igrp 1
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0

と間違えて設定しても、自動的に「172.16.0.0」に訂正されます。

「network」コマンドでは、クラスフルでアドレスを設定することに注意して下さい。

 次の「IGRPとRIPの混在時」では、IGRPとRIPの設定の両方を行った場合、IGRPのルート、RIPのルートのどちらが優先されるか検証してみます。

IGRP(debugコマンド)」 ← 前項 | 次項 → 「IGRPとRIPの混在時





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.