@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > IGRPの設定例1

 Amazon
@network Cisco・アライド実機で学ぶ
◆IGRPの設定例1

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆IGRPの設定例1

 下の図のネットワークをIGRPで構築します。設定の仕方は、RIPの設定とよく似ています。IGRPの設定を行うには、グローバル設定モードで「router igrp <AS番号>」を指定します。

 ASとは、「Autonomous System」の略で、「自律システム」と呼ばれています。1つの組織などで管理されるネットワークの集合を指します。自律システム内で、経路情報を共有します。

 IGRPの設定では、このAS番号(自律システムの番号)を指定します。EIGRPでも同様にAS番号を指定します。同じAS番号を使っているルータ間だけで経路情報が共有されます。

●IGRPを設定するコマンド

Router(config)#router igrp {AS番号}
Router(config-router)#network {ネットワーク番号}

AS番号: 1〜65,535

ネットワーク番号は、RIPと同様、クラスフルでしています。サブネットマスクは、必要ありません。

 注意点は、IGRPでは、回線の帯域幅を見ますので、「bandwidth」コマンドで帯域幅を設定するのを忘れないようにして下さい。設定を忘れると、せっかくIGRPで設定した意味がなくなってしまいます。

Router(config-if)#bandwidth {帯域幅}

帯域幅: 単位は、Kbpsで指定します。


●AS番号を合わせる

Router_A、Router_Bでは、AS番号を合わせておく必要があります。

Router_Aで

Router_A(config)#router igrp 1
Router_A(config-router)#network 172.16.0.0
Router_A(config-router)#network 172.17.0.0

Router_Bで

Router_A(config)#router igrp 2
Router_A(config-router)#network 172.16.0.0
Router_A(config-router)#network 172.17.0.0

 と設定してしまうとRouter_A、Router_Bは、異なるASに存在することになるので、経路情報が共有できなくなります。

経路情報を共有したいのであれば、AS番号は統一しておきましょう!

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
router igrp 1
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 bandwidth 64
 no fair-queue
!
router igrp 1
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
I    172.18.0.0/16 [100/8576] via 172.17.0.2, 00:00:41, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

I    172.16.0.0/16 [100/8576] via 172.17.0.1, 00:00:45, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

「I」で表示されているルートは、IGRPによって学習したことを意味します。

Router_Aでは、「172.18.0.0/16」のルート
Router_Bでは、「172.16.0.0/16」のルート

を学習していることが分かります。

それでは、この設定したIGRPネットワークを検証コマンドを使って確認してみましょう。

IGRPとは」 ← 前項 | 次項 → 「IGRP(検証コマンド)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.