@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIPv2の設定

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIPv2の設定

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIPv2の設定

 「RIP(不連続サブネットにおける問題)」で構築した、下のネットワークを今度は、RIPv2で構築してみます。設定は、とても簡単です。

ルーティングの設定の所で、「version 2」コマンドを追加するだけです。

Router(config)#router rip
Router(config-router)#version 2

 Cisco IOS 11.3より古いIOSを使用している場合は、「ip classless」コマンドを設定しないとクラスレスルーティングやデフォルトルートを使うことができません。

使用しているIOSのバージョンによっては以下のコマンドを追加して下さい。

Router(config)#ip classless


Router_A、Router_Bの各ルータで「version 2」コマンドを追加します。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 no ip address
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
R       172.16.0.0/16 [120/1] via 192.168.1.2, 00:00:19, Serial0
C       172.16.1.0/24 is directly connected, Ethernet0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
R       172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:00, Serial0
C       172.16.3.0/24 is directly connected, Ethernet0

Router_A、Router_BにRIPのルートが追加されています。

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

 Router_Aから「172.16.3.0/24」ネットワークへ対してのPingは成功し、Router_Bから「172.16.1.0/24」ネットワークへ対してのPingも成功します。

 Router_Aにおいて、「172.16.0.0」のネットワークに関しては、「172.16.0.0/16」と「172.16.1.0/24」の2つの経路が存在します。Router_Aはロンゲストマッチの法則に従って、「172.16.1.0/24」宛てのパケットは、E0に転送し、「172.16.3.0/24」宛てのパケットは、S0に転送するようになります。

RIPv2とは」 ← 前項 | 次項 → 「RIP V1、RIP V2の混在時





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.