@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIP(不連続サブネットにおける問題)

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIP(不連続サブネットにおける問題)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIP(不連続サブネットにおける問題)

 RIPやIGRPは、クラスフルルーティングプロトコルです。ルーティングアップデートの情報の中にサブネットマスクの情報を含めません。

 RIPやIGRPは、クラスフルルーティングプロトコルですが、下の図のように、連続したサブネットを配置した環境では、うまくルーティングできます。


 受信した経路情報が自分のインタフェースに設定されたネットワークアドレスが同じクラスなら、自分のインタフェースに設定されたサブネットマスクを適用するからです。このような、推測によるルーティングには、限界があります。

下の図を見て下さい。

先ほどの構成図の「172.16.2.0/24」ネットワークを「192.168.1.0/24」ネットワークに変更してみます。

ネットワークは、

(クラスB)-----(ルータA)-----(クラスC)-----(ルータB)-----(クラスB)

とネットワークは、連続サブネット環境になっていません。


上の構成の場合、RIPでルーティングできるのか検証してみます。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
!
router rip
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 no ip address
!
router rip
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.3.0 is directly connected, Ethernet0

Router_Aには、「172.16.3.0/24」のルートがありません。

Router_Bには、「172.16.1.0/24」のルートがありません。

 Router_A、Router_BにおいてRIPで宛先ネットワークを学習しきれていません。当然ながら、Router_Aから「172.16.3.0/24」ネットワークへ対してのPingは失敗しますし、Router_Bから「172.16.1.0/24」ネットワークへ対してのPingも失敗します。

 次は、このネットワークをRIP Version2で構築してみます。RIP Version2などのVLSMに対応したルーティングプロトコルでは、サブネットマスクの情報もルーティングアップデートに含めるので、不連続サブネットにおけるこのような問題でも対処できます。

次の「RIPv2とは」では、RIPv2の紹介を行います。

RIPとフローティングスタティック その2」 ← 前項 | 次項 → 「RIPv2とは





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.