@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIPとフローティングスタティック その2

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIPとフローティングスタティック その2

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIPとフローティングスタティック その2

RIPとフローティングスタティック その1」の続きです。

帯域幅が500KbpsのSerial0を経由するルートをプライマリルート

帯域幅が64KbpsのSerial0を経由するルートををバックアップルート

になるように、設定してみます。


 帯域幅の広い500Kbpsの回線を経由するルートを普段は、プライマリルートとして使用し、その回線に障害があった場合のみ帯域幅の狭い64Kbpsの回線を使うように設定します。

スタティックルートは、アドミニストレーティブディスタンスの値が変更できます。

Router(config)#ip route {ネットワーク} {サブネットマスク} {ネクストホップ|インタフェース} {AD値}

※AD値は、アドミニストレーティブディスタンスの意味

 例えば、プライマリルートがRIP、バックアップルートがスタティックルートになるように、ネットワークを構築する場合、スタティックルートのAD値をRIPのAD値120より大きい値、例えば、AD値130に変更すれば、スタティックルートは、ルーティングテーブルに登録されず、代わりにRIPで学習した経路がルーティングテーブルに登録するようになります。

 そうすると、RIPで学習した経路がダウンした時だけ、スタティックルートが使われるようになります。ちょうど、水面に沈んでいたスタティックルートが水面に浮かび上がってくるみたいです。

このスタティックルートのことをフローティングスタティック(Floating Static Route)と呼ばれています。

Router_A、Router_Bのルーティングの設定は以下のように設定します。

●Router_A

Router_Aでは、

RIPのルーティングの設定を以下のようにします。

Router_A(config)#ip route 172.18.0.0 255.255.0.0 192.168.1.2 130

Router_A(config)#router rip
Router_A(config-router)#network 172.16.0.0
Router_A(config-router)#network 172.17.0.0

●Router_B

Router_Bでは、

RIPのルーティングの設定を以下のようにします。

Router_B(config)#ip route 172.16.0.0 255.255.0.0 192.168.1.1 130

Router_B(config)#router rip
Router_B(config-router)#network 172.17.0.0
Router_B(config-router)#network 172.18.0.0

各ルータの設定は、以下のようになります。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 bandwidth 500
 clockrate 500000
!
interface Serial1
 ip address 192.168.1.1 255.255.255.0
 bandwidth 64
 clockrate 64000
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
ip route 172.18.0.0 255.255.0.0 192.168.1.2 130
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 bandwidth 500
 no fair-queue
!
interface Serial1
 ip address 192.168.1.2 255.255.255.0
 bandwidth 64
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
ip route 172.16.0.0 255.255.0.0 192.168.1.1 130
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:04, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:03, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

Router_Aでは、「172.18.0.0/16」のルートが、Seial0を経由するルートに
Router_Bでは、「172.16.0.0/16」のルートが、Seial0を経由するルートに

になっています。

スタティックルートのAD値が130とRIPのAD値120より大きいので、RIPのルートが優先されたわけです。


Router_AのSerial0につなげているケーブルを抜きます。

そして、ルーティングテーブルを確認します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
C    172.16.0.0/16 is directly connected, Ethernet0
S    172.18.0.0/16 [130/0] via 192.168.1.2

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
S    172.16.0.0/16 [130/0] via 192.168.1.1
C    172.18.0.0/16 is directly connected, Ethernet0

 スタティックルートが浮かび上がってきました。RIPルートがダウンしたため、RIPよりAD値が高く設定されたスタティックルートが浮かび上がってきたわけです。

こんどは、また、先ほどはずした、Router_AのSerial0につなげているケーブルを接続しなおします。


そして、ルーティングテーブルを確認します。

反映されるには、少し時間がかかります。

Router#clear ip route *

 コマンドを使って強制的にルーティングテーブルを削除してから、「show ip route」コマンドで確認してみてもよいと思います。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:04, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial1
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:03, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

このように、フローティングスタティックルートは、バックアップ経路として活用できます。

RIPとフローティングスタティック その1」 ← 前項 | 次項 → 「RIP(不連続サブネットにおける問題)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.