@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIP(等コストロードバランシング その2)

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIP(等コストロードバランシング その2)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIP(等コストロードバランシング その2)

RIP(等コストロードバランシング その1)」の続きです。

ネットワークの構成は、以下のようになります。


プロセススイッチングによる等コストロードバランスの設定を行うには、下のコマンドを使います。

Router(config-if)#no ip route-cash

 このコマンドを設定する前に、「show ip interface」コマンドを使って、ファストスイッチングが有効になっているかどうか調べてみます。

●「show ip interface」の出力
Router_A#show ip interface serial 0
Serial0 is up, line protocol is up
  Internet address is 172.16.2.1/24
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is enabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP multicast fast switching is enabled
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  Probe proxy name replies are disabled
  Gateway Discovery is disabled
  Policy routing is disabled

上の黄色い網掛けを見てもらうと分かるとおりデフォルトでファストスイッチングが有効になっているのが分かります。

それでは、

 Router_AのSerial0、Seial1と、Router_BのSerial0、Seial1で「no ip route-cash」コマンドを適用してみましょう!

Router(config-if)#no ip route-cash

●Router_A

Router_A(config)#interface serial 0
Router_A(config-if)#no ip route-cash
Router_A(config-if)#exit
Router_A(config)#interface serial 1
Router_A(config-if)#no ip route-cash

●Router_B

Router_A(config)#interface serial 0
Router_A(config-if)#no ip route-cash
Router_A(config-if)#exit
Router_A(config)#interface serial 1
Router_A(config-if)#no ip route-cash

「show ip interface」コマンドを使って、ファストスイッチングが無効になっているかどうか調べてみます。

●「show ip interface」の出力
Router_A#show ip interface serial 0
Serial0 is up, line protocol is up
  Internet address is 172.16.2.1/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is enabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is disabled
  IP fast switching on the same interface is disabled
  IP multicast fast switching is disabled
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  Probe proxy name replies are disabled
  Gateway Discovery is disabled
  Policy routing is disabled

Router_Bに「debug ip packet」コマンドを実行して、Router_AからのPingを監視します。

Router_B#debug ip packet

 Router_Aで、拡張Pingを行い、送信元IPアドレスを172.16.1.1、宛先IPアドレス172.16.4.1へ向けて、100回Pingパケットを送信します。

●Router_AからのPing
Router_A#ping
Protocol [ip]:
Target IP address: 172.16.4.1
Repeat count [5]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echoes to 172.16.4.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 32/35/64 ms

直ぐに、Router_Bに切り替えて、「debug ip packet」の出力を確認します。

●Router_Bの「debug ip packet」の出力
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4

Serial0、Serial1が切り替わっていることが確認できます。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 clockrate 64000
!
interface Serial1
 ip address 172.16.3.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 clockrate 64000
!
router rip
 network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 no fair-queue
!
interface Serial1
 ip address 172.16.3.2 255.255.255.0
 no ip mroute-cache
 no ip route-cache
!
router rip
 network 172.16.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

RIP(等コストロードバランシング その1)」 ← 前項 | 次項 → 「RIPとスタティックルートの混在時





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.