@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIP(等コストロードバランシング その1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIP(等コストロードバランシング その1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIP(等コストロードバランシング その1)

 RIPでは、コストの等しいパスをラウンドロビン形式で、ロードバランシングを行うことができます。デフォルトで4本のパスにまたがってロードバランシングを行うことができますが、「maximum-paths」コマンドを使用することで、最大6本までの、ロードバランシングを行うことができます。

ちなみに、IGRP、EIGRPでは、不等コストロードバランシングもサポートされています。

それでは、下の図のようなネットワークを構築して、RIPの等コストロードバランシングの設定を行ってみましょう!


ロードバランシングには、次の2種類あります。

・プロセススイッチング
・ファストスイッチング

●プロセススイッチング

 プロセススイッチングは、パケット単位でロードバランシングします。両方のインタフェースで、プロセススイッチングを設定することで、パケット単位でロードバランシングするようになります。ほとんどのシスコ ルータでは、デフォルトでファーストスイッチングがインターフェイスに対して有効化されています。

今回は、プロセススイッチングでロードバランシングを行うので、次のコマンドを実行します。

Router(config-if)#no ip route-cash

●ファストスイッチング

 ファストスイッチングは、高速キャッシュを参照してパケットを 送信先ごとのロードバランシングを行います。シスコルータの多くは、デフォルトでこのファストスイッチングが、有効になっています。

それでは、まず、上の図でRIPルーティングを行うように設定してみましょう!

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 clockrate 64000
!
interface Serial1
 ip address 172.16.3.1 255.255.255.0
 clockrate 64000
!
router rip
 network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no fair-queue
!
interface Serial1
 ip address 172.16.3.2 255.255.255.0
!
router rip
 network 172.16.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

RIPの設定が完了したら、Router_A、Router_Bのルーティングテーブルを確認してみましょう。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 4 subnets
R       172.16.4.0 [120/1] via 172.16.2.2, 00:00:03, Serial0
                   [120/1] via 172.16.3.2, 00:00:03, Serial1
C       172.16.1.0 is directly connected, Ethernet0
C       172.16.2.0 is directly connected, Serial0
C       172.16.3.0 is directly connected, Serial1

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.4.0 is directly connected, Ethernet0
R       172.16.1.0 [120/1] via 172.16.2.1, 00:00:23, Serial0
                   [120/1] via 172.16.3.1, 00:00:23, Serial1
C       172.16.2.0 is directly connected, Serial0
C       172.16.3.0 is directly connected, Serial1

 Router_Aでは、「172.16.4.0」へのルートが2つ、Router_Bでは、「172.16.1.0」へのルートが2つあることが確認できます。

 続きは、「RIP(等コストロードバランシング その2)」でプロセススイッチングによる等コストロードバランシングの設定を行ってゆきます。

RIP(debugコマンド)」 ← 前項 | 次項 → 「RIP(等コストロードバランシング その2)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.