@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIP(passive-interface)

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIP(passive-interface)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIP(passive-interface)

 「RIPの設定例2」では、下のようなネットワークをRIPで構築しました。このネットワークを利用して、「passibe-interface」コマンドについて紹介します。


Router_Aで、RIPの設定を

Router(config)#router rip
Router(config-router)#network 172.16.0.0

Router_Bでも同様に、RIPの設定を

Router(config)#router rip
Router(config-router)#network 172.16.0.0

で設定すると、RIPのアップデートが、各インタフェース上から宛先アドレス「255.255.255.255」で送信されるようになります。

 これで、基本的にRIPの設定はOKなのですが、ちょっと待って下さい。「172.16.1.0」と「172.16.3.0」ネットワークには、RIPのアップデートを受け取るルータが存在しません。RIPのアップデート情報を受け取る相手がいないのに、ネットワーク上にアップデート情報を流しても意味がありません。

RIPは、『おしゃべりなプロトコル』で有名なプロトコルです。

 アップデートの送信間隔が、30秒と頻繁にアップデート情報を流しています。しかも、ディスタンスベクタのプロトコルですから、ルーティングテーブルの情報を丸ごと送信しています。

 この不要な、ルーティングアップデートを止めるコマンドが「passive-interface」コマンドです。「passive-interface」コマンドは、ルーティングのアップデートは、受信しますが、送信をストップさせることができます。

Router(config)#pasive-interface {インタフェース名} {インタフェース番号}

Router_Aで

Router(config)#router rip
Router(config-router)#passive-interface e0

Router_Bで

Router(config)#router rip
Router(config-router)#passive-interface e0

 と設定すれば、余計なルーティングアップデートのトラフィックが流れずに済みますが、確認のするのが、少々大変なので、Router_AのS0からのルーティングアップデートを止めることで、アップデートが止められているのか確認してみます。


Router_Aで、

Router_A(config)#router rip
Router_A(config-router)#passive-interface s0

と設定します。

Router_A、Router_Bでルーティングテーブルを参照してみましょう。

ルーティングテーブルは、直ぐに反映されません。反映されるには、しばらく時間がかかります。

しばらく、待ってからルーティングテーブルを確認する必要があります。


●「clear ip route *」コマンド

そこで、

Router_A、Router_Bのそれぞれで、

router#clear ip route *

「router#clear ip route *」コマンドを入力します。

 そうすると、強制的にルーティングテーブルをクリアすることができます。Router_A、Router_Bのそれぞれで、ルーティングテーブルを確認してみましょう。

Router_Aでは、ルーティングテーブルは以下のようになります。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C       172.16.1.0 is directly connected, Ethernet0
C       172.16.2.0 is directly connected, Serial0
R       172.16.3.0 [120/1] via 172.16.2.2, 00:00:12, Serial0

 Router_Aでは、Router_BからRIPのルーティングアップデートを受け取っているので、ネットワーク上の全てのエントリが見えているはずです。

Router_Bでは、ルーティングテーブルは以下のようになります。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.2.0 is directly connected, Serial0
C       172.16.3.0 is directly connected, Ethernet0

Router_AからRIPのアップデートを受け取らないので、「172.16.1.0」のエントリーがないはずです。

このように、「passive-interface」コマンドを設定すると余計なトラフィックを流さないで済みます。

特に、WANリンクでは、余計なトラフィックが発生しないように心がける必要があります。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 passive-interface Serial0
 network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 172.16.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

RIPの設定例2」 ← 前項 | 次項 → 「RIP(debugコマンド)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.