@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > ルータの設定をコピーペーストで設定する

 Amazon
@network Cisco・アライド実機で学ぶ
◆ルータの設定をコピーペーストで設定する

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆ルータの設定をコピーペーストで設定する

保存しておいた設定ファイルをルータに適応させるには、いくつか方法があります。

●ターミナルソフトの「ファイル」メニューを展開して設定ファイルを指定し転送する方法

●copy tftp running-config コマンドを使ってTFTPサーバ上の設定ファイルを指定する方法

などの方法がありますが、ここでは、もっと簡単な方法を紹介します。

まず、設定を保存したテキストファイルを開きます。


インタフェースの設定のところで、「no shutdown」コマンドを追加しておきます。

 基本的に、設定ファイルを転送する際は、あらかじめルータの設定を空にしておきます。ルータの設定が空の場合、インタフェースはデフォルトで「shutdown」になっています。

 転送する設定ファイルに「no shutdown」コマンドを追加していない場合は、転送後、各インタフェースがdownしたままの状態になっています。

 後から、各インタフェース設定モードに入って「no shutdown」コマンドを入力するのは面倒なので、「no shutdown」を入れておきましょう!


 「no shutdown」コマンドを追加したら転送したい部分を選択して、「Ctrl + C」キーを押してクリップボードにコピーしておきます。


ルータにクリップボードにコピーした内容をルータに流し込みます。

ルータに設定を流し込むには、グローバル設定モードに移行する必要があります。

ここが、重要です。

 もし間違えて、違う設定モードでクリップボードの内容をルータに流し込むと、ルータがコマンドが解釈できなかったり、DNSにてコマンド名をホスト名として名前解決しようとして、しばらくの間、固まってしまいます。

ルータに設定を流し込む際は、必ずグローバル設定モードに移行しているかどうか確認してから行いましょう!

それでは、設定をルータに流し込んでみます。

グローバル設定モードで、

Router(config)#

のプロンプトのところで、「Ctrl + V」キーを押します。クリップボードにコピーしていた内容がルータ上で展開されます。

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#! ← ここで、コピーペーストを行います
Router(config)#version 11.1
Router(config)#service udp-small-servers
Router(config)#service tcp-small-servers
Router(config)#!
Router(config)#hostname Router_A
Router_A(config)#!
Router_A(config)#enable password cisco
Router_A(config)#!
Router_A(config)#ip subnet-zero
Router_A(config)#!
Router_A(config)#interface Ethernet0
Router_A(config-if)# ip address 192.168.1.1 255.255.255.0
Router_A(config-if)# no shutdown
Router_A(config-if)#!
Router_A(config-if)#router ospf 1
Router_A(config-router)# network 192.168.1.0 0.0.0.255 area 0
Router_A(config-router)#!
Router_A(config-router)#ip classless
Router_A(config)#!
Router_A(config)#line con 0
Router_A(config-line)#line aux 0
Router_A(config-line)#line vty 0 4
Router_A(config-line)# password cisco
Router_A(config-line)# login
Router_A(config-line)#!
Router_A(config-line)#end
Router_A#

 このルータへの設定ファイルの流し込む方法を使えば、わざわざ各ルータで1つずつコマンドで設定しなくても済みます。テキストファイル上で設定内容を編集することで、ルータの設定時間を短縮することができます!

traceroute」 ← 前項 | 次項 → 「logging synchronous コマンド





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.