@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > スタティックルーティング(その2)

 Amazon
@network Cisco・アライド実機で学ぶ
◆スタティックルーティング(その2)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆スタティックルーティング(その2)

 先ほどの「スタティックルーティング(その1)」で構築したネットワークは、ルートの向きが一方行で、ルートの向きについて考える必要がありませんでした。

今度は、下の図のネットワークをスタティックルートで、ネットワークを構築してみます。

 静的ルートの設定では、宛先ネットワークへ到達するために、隣のどのルータのどのインタフェースにパケットを渡してやるのか指定してゆきます。


 各ルータの、ルートの向きは、下のようになります。Router_Bのルートの向きに注目して下さい。宛先ネットワークによって、ネクストホップの指定が変わってきます。

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.3.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24

 ルートの設定では、宛先ネットワークへ到達するために、隣のどのルータのどのインタフェースにパケットを渡してやるのか指定してゆくようになります。

※自分(ルータ)のどのインタフェースからパケットを送信すればよいのかを指示することもできます。

Rotuer_Bのルートの設定は、以下のようになります。

Router(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
Router(config)#ip route 172.16.4.0 255.255.255.0 172.16.3.2

 スタティックルート設定では、ルートの向きに気をつけて下さい。ルーティングテーブルに間違った経路情報があると、正しく宛先にパケットを配送できなくなります。

●Router_Aのコンフィグ
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 172.16.3.0 255.255.255.0 172.16.2.2
ip route 172.16.4.0 255.255.255.0 172.16.2.2
!
line con 0
line aux 0
line vty 0 4
 login
!
end

●Router_Bのコンフィグ
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no fair-queue
!
interface Serial1
 ip address 172.16.3.1 255.255.255.0
 clockrate 64000
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 172.16.4.0 255.255.255.0 172.16.3.2
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

●Router_Cのコンフィグ
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.3.2 255.255.255.0
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1
ip route 172.16.2.0 255.255.255.0 172.16.3.1
!
line con 0
line aux 0
line vty 0 4
 login
!
end

スタティックルーティング(その1)」 ← 前項 | 次項 → 「デフォルトルートとip classless





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.